AntMe! 1.7.2 is out

Veröffentlicht: 16 Februar 2015 in AntMe!
Schlagwörter:, ,

Und wieder gibt’s ein kleines Update für unser allseits beliebtes Ameisenspiels. Diesmal gehen die Veränderungen aber eher Richtung Bugfixing und interne Änderungen. Aber das offensichtlichste zuerst: Der neue Dialog für die Konfiguration eines freien Spiels. Er orientiert sich jetzt etwas mehr an gängigen Strategiespielen und bietet die verfügbaren Spielerslots für die KI-Zuweisung an. Damit einher gingen ein paar Änderungen im Ablauf der Spiel-Konfiguration.

freegame

Warum das Ganze? Ganz einfach. Mit der Online Anbindung und weiteren Ideen werden neue Spiel-Modi in Form von neuen Plugins hinzukommen. Dabei teilen sich diese Modi ein paar zentrale Funktionen wie beispielsweise die Auswahl der Spieler KI. Deshalb gibt es jetzt auch eine weitere Assembly „PlayerManagement“ für diverse Auswahl-Dialoge.

Sonstige Veränderungen in der Schnell-Übersicht

  • Plugins werden jetzt nur noch aus dem Programm-Pfad geladen
  • Änderungen bei der Plugin-Selektierung werden sofort gespeichert (dann wichtig, wenn man im Spielmodus das Programm direkt über Visual Studio stoppt)
  • Source oder Quelle heißt jetzt Mode bzw. Modus. Außerdem ist die Auswahl-Combo Box im Hauptfenster durch ein ordentliches Menü ersetzt.
  • XNA Anzeige hat eine Info-Seite zur Steuerung bekommen
  • XNA Lokalisierung funktioniert jetzt richtig
  • Es gibt jetzt einen VB.NET Code Generator für deutsch und englisch
  • Kaputte Kreis-Ameisen entfernt 😉

Für kommende Update stehen noch ein paar wirklich wichtige Dinge auf dem Plan. Lasst mich aber wie immer gerne wissen, was ihr vermisst, dringend braucht, cool fändet,…

  • Fehlerhafte Simulation (Falsche Angaben bei „ZurückgelegteStrecke“, Berechnung von „BrauchtNochTräger“ und maximale Markierungsgröße,…)
  • Zufallsgenerator für die Maps überarbeiten
  • Dokumentation

Also direkt mal downloaden!!!

Ich wünsche wie immer ganz viel mit den Ameisen
Euer Tom

Advertisements
Kommentare
  1. Tim sagt:

    Läuft AntMe auf Windows 8 (64Bit)?

    • tomwendel sagt:

      Hallo Tim.
      Diese Frage kann ich mit ruhigem Gewissen mit Ja beantworten. Ich selbst arbeite hauptsächlich mit Windows 8 (x64). Allerdings Desktop, nicht RT.
      RT funktioniert wegen der Abhängigkeit zu einer IDE leider nicht.
      Tom

      • Tim sagt:

        Hallo Tom,
        ich habe AntMe und die zwei Frameworks (.NET Framework, .XNA Framework) installiert. Als Entwicklungsumgebung wollte ich die Visual Basic 2010 Express Edition verwenden. Beim Erstellen einer neuen Kolonie wird das Öffnen der Entwicklungsumgebung mit der sinngemäßen Fehlermeldung „… die SLN-Datei wurde mit einer neueren Version erstellt“ abgebrochen. Eine Visual Basic 2013 Express Edition konnte ich jedoch nicht finden.
        Welche Version soll ich installieren?

        Tim

      • tomwendel sagt:

        Hallo Tim,

        Visual Studio hat schon einige Monde auf dem Buckel und wurde inzwischen von 2,5 Generationen Visual Studio überholt, weshalb wir keinen Template-Generator mehr dafür integriert haben. Die erzeugten Projekte sind aber mit VS 2012 und VS 2013 kompatibel. Passende Downloads für die kostenfreien Express-Editionen und die neue, mächtigere Community Edition gibt es hier:

        https://www.visualstudio.com/de-de/downloads/download-visual-studio-vs.aspx

        Viele Grüße
        Tom

  2. Nils sagt:

    Hallo Tom,
    Ich habe ein Problem: Wenn ich aus Visual Studio 2013 Community Editon AntMe starte und meine AmeisenKolonie Einfüge und dann oben links auf Play drücke, dann sehe ich zwar wie unt in der staus Leiste angezeigt wird wie die Zeit Läuft aber es erscheint bei mir kein Fenster mit der Siulation. Ich habe alle Frameworks schon neuinstalliert und auch AntMe geupdated aber es will sich kein Fenster öffnen.

    Viele Grüße
    Nils

    • tomwendel sagt:

      Hallo Nils,

      das klingt, als ob das 3D-Plugin aus irgend einem Grund nicht aktiviert wäre. Werf doch mal einen Blick in Einstellungen/Plugins und schau, ob ein Haken für das entsprechende Ausgabe-Plugin fehlt.

      Viele Grüße und Erfolg
      Tom

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s